Forum Supportu Strona Główna Forum Supportu
czo.pl/wxv.pl

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy  StatystykiStatystyki
RejestracjaRejestracja  ZalogujZaloguj  AlbumAlbum  DownloadDownload

Poprzedni temat «» Następny temat
problem z nagłówkiem na podstronach po aktualizacji
Autor Wiadomość
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-08-29, 22:04   problem z nagłówkiem na podstronach po aktualizacji
  


mam problem po aktualizacji php by przemo. używam stylu bblack. przedtem po kliknięciu w nagłówek w podstronie przekierowywało na stronę główną forum. po aktualizacji na podstronach po kliknięciu w nagłówek przerzuca na tą samą podstronę na której obecnie jestem. nie wiem jak to naprawić. może ktoś coś podpowie
 
     
Mich@ł
Administrator

Wpisz dowolną liczbę: 1234567890
Pomógł: 160 razy
Dołączył: 07 Sie 2009
Posty: 3219
Wysłany: 2015-08-29, 22:08   
  


ainer1985,
W szablonie edytujsz plik overal_header.tpl
Znajdź:
Kod:
    <tr>
        <td align="center"><a href="">
            <img src="templates/bblack/images/top_swieta.png" width=900 height=180 border="0" alt=""></a></td>
    </tr>


tutaj wpisz adres forum:
Cytat:
<td align="center"><a href="">
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-08-30, 09:04   
  


Mich@ł napisał/a:
ainer1985,
W szablonie edytujsz plik overal_header.tpl
Znajdź:
Kod:
    <tr>
        <td align="center"><a href="">
            <img src="templates/bblack/images/top_swieta.png" width=900 height=180 border="0" alt=""></a></td>
    </tr>


tutaj wpisz adres forum:
Cytat:
<td align="center"><a href="">


Dziękuję bardzo. Pomogło. I dziękuję za szybką odpowiedź.
miałam tam wpisane <td align="center"><a href="{U_INDEX_PORTAL}"> i powinno działać, także nie wiem czy coś jest nie tak z tym parametrem po aktualizacji. Coś widzę, że będę częściej zaglądać na to forum :)
Jeszcze raz dziękuję Mich@ł
 
     
Mich@ł
Administrator

Wpisz dowolną liczbę: 1234567890
Pomógł: 160 razy
Dołączył: 07 Sie 2009
Posty: 3219
Wysłany: 2015-08-30, 09:49   
  


ainer1985, są pewne zmiany, a konkretniej w wersji 1.12.9 usunięto portal i to jest najprawdopodobniej przyczyną nie działania tego "tagu" ;)
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-08-30, 13:31   
  


i chyba moduł urodzin, bo nie wyświetla mi się nic tam. Wyświetla mi się teraz coś takiego:


I jeszcze posypały mi się polskie znaki w starych tematach. tych utworzonych przed aktualizacją. Ale źle się wyświetlają tylko na stronie głównej. jak wchodzi się w temat to jest ok. Ale to już w mysql muszę pogrzebać.
Jeszcze raz dziękuję za pomoc :)
 
     
Mich@ł
Administrator

Wpisz dowolną liczbę: 1234567890
Pomógł: 160 razy
Dołączył: 07 Sie 2009
Posty: 3219
Wysłany: 2015-08-30, 14:41   
  


http://adpsubs.pl/check_files.php

W phpmyadmin musisz dodać te zapytania:
Kod:
INSERT INTO `phpbb_config` (config_name, config_value) VALUES ('ri_data', '');
INSERT INTO `phpbb_config` (config_name, config_value) VALUES ('ri_time', '');
UPDATE `phpbb_config` SET `config_value` = '1.12.9' WHERE `config_name` = 'version';


Co do kodowania to o ile wcześniej miałaś wersje 1.12.8 to nie powinno być żadnych problemów bo w niej już była zmiana kodowania na latin2.

Na liście zmian nie widzę nic o usunięciu modułu urodzin, może jest on przebudowany jedynie bo są zmiany w MySQL.
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-08-30, 18:04   
  


niestety usunęli moduł urodzin:
- usunięcie birthday moda
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-08-31, 20:52   
  


No i znalazłam jeszcze jeden błąd przy próbie rejestracji nowego użytkownika wyrzuca:
Cytat:
Błąd Ogólny

Could not insert data into users table

DEBUG MODE

INSERT INTO phpbb_users (username, user_regdate, user_password, user_email, user_icq, user_website, user_occ, user_interests, user_from, user_sig, user_sig_bbcode_uid, user_sig_image, user_avatar, user_avatar_type, user_viewemail, user_viewaim, user_aim, user_yim, user_msnm, user_attachsig, user_allowsmile, user_allowhtml, user_allowbbcode, user_allow_viewonline, user_notify, user_notify_gg, user_notify_pm, user_popup_pm, user_timezone, user_lang, user_custom_color, user_custom_rank, user_style, user_gender, allowpm, user_level, user_allow_pm, user_ip, user_ip_login_check, user_active, user_actkey) VALUES ('ainertest', 1441050430, '$H$96wnry9q7XLBkf2DZ/rGmpeDFz6LoW1', 'ccccc@gmail.com', '', '', '', '', 'fff', '', '', '', '', 0, 1, 1, '', '', '', 1, 1, 1, 1, 1, 0, 0, 1, 1, 1, 'polish', '', '', 65, '2', 1, 0, 1, '9fcd2037', 1, 0, 'cd4a8f7da2ce5c1e312713adc')

Line : 883
File : usercp_register.php
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-08-31, 21:18   
  


$sql = "INSERT INTO " . USERS_TABLE . " (username, user_regdate, user_password, user_email, user_icq, user_website, user_occ, user_interests, user_from, " . $sql_custom_fields . " user_sig, user_sig_bbcode_uid, user_sig_image, user_avatar, user_avatar_type, user_viewemail, user_viewaim, user_aim, user_yim, user_msnm, user_attachsig, user_allowsmile, user_allowhtml, user_allowbbcode, user_allow_viewonline, user_notify, user_notify_gg, user_notify_pm, user_popup_pm, user_timezone, user_lang, user_custom_color, user_custom_rank, user_style, user_gender, allowpm, user_level, user_allow_pm, user_ip, user_ip_login_check, user_active, user_actkey)
VALUES ('" . str_replace("\'", "''", $username) . "', " . CR_TIME . ", '" . str_replace("\'", "''", $new_password) . "', '" . str_replace("\'", "''", $email) . "', '" . str_replace("\'", "''", $icq) . "', '" . str_replace("\'", "''", $website) . "', '" . str_replace("\'", "''", $occupation) . "', '" . str_replace("\'", "''", $interests) . "', '" . str_replace("\'", "''", $location) . "', " . $sql_custom_values . " '" . str_replace("\'", "''", $signature) . "', '$signature_bbcode_uid', $signature_sql, $avatar_sql, $viewemail, $viewaim, '" . str_replace("\'", "''", str_replace(' ', '+', $aim)) . "', '" . str_replace("\'", "''", $yim) . "', '" . str_replace("\'", "''", $msn) . "', $attachsig, $allowsmilies, $allowhtml, $allowbbcode, $allowviewonline, $notifyreply, $user_notify_gg, $notifypm, $popuppm, $user_timezone, '" . str_replace("\'", "''", $user_lang) . "', '" . str_replace("\'", "''", $custom_color) . "', '" . str_replace("\'", "''", $custom_rank) . "', $user_style, '$gender', $allowpm, 0, 1, '$user_ip', $user_ip_login_check, ";

if ( $board_config['require_activation'] == USER_ACTIVATION_SELF || $board_config['require_activation'] == USER_ACTIVATION_ADMIN || $coppa )
{
$user_actkey = gen_rand_string(true);
$key_len = 54 - (strlen($server_url));
$key_len = ( $key_len > 6 ) ? $key_len : 6;
$user_actkey = substr($user_actkey, 0, $key_len);
$sql .= "0, '" . str_replace("\'", "''", $user_actkey) . "')";
}
else
{
$sql .= "1, '')";
}

if ( !($result = $db->sql_query($sql, BEGIN_TRANSACTION)) )
{
Kod:
message_die(GENERAL_ERROR, 'Could not insert data into users table', '', __LINE__, __FILE__, $sql);

}

$user_id = $db->sql_nextid();
if ( $board_config['allow_photo_upload'] && $mode != 'register' )
{
$profilephoto_mod->photo_insert($mode);
}

$sql = "INSERT INTO " . GROUPS_TABLE . " (group_name, group_description, group_single_user, group_moderator)
VALUES ('', 'Personal User', 1, 0)";
if ( !($result = $db->sql_query($sql)) )
{
message_die(GENERAL_ERROR, 'Could not insert data into groups table', '', __LINE__, __FILE__, $sql);
}

$group_id = $db->sql_nextid();

$sql = "INSERT INTO " . USER_GROUP_TABLE . " (user_id, group_id, user_pending)
VALUES ($user_id, $group_id, 0)";
if ( !($result = $db->sql_query($sql, END_TRANSACTION)) )
{
message_die(GENERAL_ERROR, 'Could not insert data into user_group table', '', __LINE__, __FILE__, $sql);
}
 
     
Mich@ł
Administrator

Wpisz dowolną liczbę: 1234567890
Pomógł: 160 razy
Dołączył: 07 Sie 2009
Posty: 3219
Wysłany: 2015-08-31, 23:23   
  


ainer1985, zerknij na ten temat:

http://www.przemo.org/phpBB2/forum/viewtopic.php?p=800930

Powinno pomóc ;)
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-09-01, 06:52   
  


no to mam:
Cytat:
#1054 - Unknown column 'user_field_1' in 'field list'
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-09-01, 07:09   
  


czyli musiałabym dodać kolumnę user_field_1 do tabeli phpbb_users?
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-09-01, 07:15   
  


sorki mój błąd. nie zamieniłam zapytania na swój przypadek. przyznaję blondynka. :)
wyskakuje po zapytaniu :
Cytat:
#1062 - Duplicate entry '0' for key 'PRIMARY'
 
     
Mich@ł
Administrator

Wpisz dowolną liczbę: 1234567890
Pomógł: 160 razy
Dołączył: 07 Sie 2009
Posty: 3219
Wysłany: 2015-09-01, 09:37   
  


ainer1985,
http://www.przemo.org/phpBB2/forum/viewtopic.php?p=800965#800965 lenistwo... ;)


Robiłaś aktualizację forum z wersji 1.12.8 ;)?
 
     
ainer1985

Wpisz dowolną liczbę: 432355
Dołączył: 29 Sie 2015
Posty: 10
Wysłany: 2015-09-01, 22:12   
  


Tak aktualizowałam z wersji ...8. Już pomogło ten temat z linku. Szukałam na forum przema, ale nie mogłam znaleźć :-( dzięki po raz nty :-)
 
     
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Strona wygenerowana w 0,43 sekundy. Zapytań do SQL: 9
Reklama